GLSA-201903-20 : cabextract, libmspack: Multiple vulnerabilities

Medium Nessus Plugin ID 123426

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201903-20 (cabextract, libmspack: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in cabextract and libmspack. Please review the CVE identifiers referenced below for details.
Impact :

Please review the referenced CVE’s for details.
Workaround :

There is no known workaround at this time.

Solution

All cabextract users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-arch/cabextract-1.8' All libmspack users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/libmspack-0.8_alpha'

See Also

https://security.gentoo.org/glsa/201903-20

Plugin Details

Severity: Medium

ID: 123426

File Name: gentoo_GLSA-201903-20.nasl

Version: 1.2

Type: local

Published: 2019/03/28

Updated: 2019/08/12

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:cabextract, p-cpe:/a:gentoo:linux:libmspack, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2019/03/28

Vulnerability Publication Date: 2018/07/28

Reference Information

CVE: CVE-2018-14679, CVE-2018-14680, CVE-2018-14681, CVE-2018-14682, CVE-2018-18584, CVE-2018-18585, CVE-2018-18586

GLSA: 201903-20