RHEL 2.1 : apache (RHSA-2002:251)

High Nessus Plugin ID 12332


The remote Red Hat host is missing one or more security updates.


Updated apache and httpd packages are available which fix a number of security issues for Red Hat Linux Advanced Server 2.1.

[Updated 06 Feb 2003] Added fixed packages for Advanced Workstation 2.1

The Apache HTTP server is a powerful, full-featured, efficient, and freely-available Web server.

Buffer overflows in the ApacheBench support program (ab.c) in Apache versions prior to 1.3.27 allow a malicious Web server to cause a denial of service and possibly execute arbitrary code via a long response. The Common Vulnerabilities and Exposures project has assigned the name CVE-2002-0843 to this issue.

Two cross-site scripting vulnerabilities are present in the error pages for the default '404 Not Found' error, and for the error response when a plain HTTP request is received on an SSL port. Both of these issues are only exploitable if the 'UseCanonicalName' setting has been changed to 'Off', and wildcard DNS is in use. These issues would allow remote attackers to execute scripts as other Web page visitors, for instance, to steal cookies. These issues affect versions of Apache 1.3 before 1.3.26, and versions of mod_ssl before 2.8.12.
The Common Vulnerabilities and Exposures project has assigned the names CVE-2002-0840 and CVE-2002-1157 to these issues.

The shared memory scoreboard in the HTTP daemon for Apache 1.3, prior to version 1.3.27, allowed a user running as the 'apache' UID to send a SIGUSR1 signal to any process as root, resulting in a denial of service (process kill) or other such behavior that would not normally be allowed. The Common Vulnerabilities and Exposures project has assigned the name CVE-2002-0839 to this issue.

All users of the Apache HTTP server are advised to upgrade to the applicable errata packages. For Red Hat Linux Advanced Server 2.1 these packages include Apache version 1.3.27 which is not vulnerable to these issues.

Note that the instructions in the 'Solution' section of this errata contain additional steps required to complete the upgrade process.


Update the affected packages.

See Also







Plugin Details

Severity: High

ID: 12332

File Name: redhat-RHSA-2002-251.nasl

Version: $Revision: 1.16 $

Type: local

Agent: unix

Published: 2004/07/06

Modified: 2016/12/28

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:apache, p-cpe:/a:redhat:enterprise_linux:apache-devel, p-cpe:/a:redhat:enterprise_linux:apache-manual, p-cpe:/a:redhat:enterprise_linux:mod_ssl, cpe:/o:redhat:enterprise_linux:2.1

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2003/02/05

Reference Information

CVE: CVE-2002-0839, CVE-2002-0840, CVE-2002-0843, CVE-2002-1157

RHSA: 2002:251