Scientific Linux Security Update : firefox on SL6.x i386/x86_64 (20190320)

High Nessus Plugin ID 123057

Synopsis

The remote Scientific Linux host is missing one or more security updates.

Description

This update upgrades Firefox to version 60.6.0 ESR.

Security Fix(es) :

- Mozilla: Memory safety bugs fixed in Firefox 66 and Firefox ESR 60.6 (CVE-2019-9788)

- Mozilla: Use-after-free when removing in-use DOM elements (CVE-2019-9790)

- Mozilla: Type inference is incorrect for constructors entered through on-stack replacement with IonMonkey (CVE-2019-9791)

- Mozilla: IonMonkey leaks JS_OPTIMIZED_OUT magic value to script (CVE-2019-9792)

- Mozilla: Improper bounds checks when Spectre mitigations are disabled (CVE-2019-9793)

- Mozilla: Type-confusion in IonMonkey JIT compiler (CVE-2019-9795)

- Mozilla: Use-after-free with SMIL animation controller (CVE-2019-9796)

- Mozilla: Proxy Auto-Configuration file can define localhost access to be proxied (CVE-2018-18506)

Solution

Update the affected firefox and / or firefox-debuginfo packages.

See Also

http://www.nessus.org/u?2192cde3

Plugin Details

Severity: High

ID: 123057

File Name: sl_20190320_firefox_on_SL6_x.nasl

Version: 1.5

Type: local

Agent: unix

Published: 2019/03/25

Updated: 2020/05/29

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:fermilab:scientific_linux:firefox, p-cpe:/a:fermilab:scientific_linux:firefox-debuginfo, x-cpe:/o:fermilab:scientific_linux

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/03/20

Vulnerability Publication Date: 2019/02/05

Reference Information

CVE: CVE-2018-18506, CVE-2019-9788, CVE-2019-9790, CVE-2019-9791, CVE-2019-9792, CVE-2019-9793, CVE-2019-9795, CVE-2019-9796