Fedora 28 : xen (2019-bce6498890)

High Nessus Plugin ID 123046

Synopsis

The remote Fedora host is missing a security update.

Description

xen: various flaws (#1685577) grant table transfer issues on large hosts [XSA-284] race with pass-through device hotplug [XSA-285] x86:
steal_page violates page_struct access discipline [XSA-287] x86:
Inconsistent PV IOMMU discipline [XSA-288] missing preemption in x86 PV page table unvalidation [XSA-290] x86/PV: page type reference counting issue with failed IOMMU update [XSA-291] x86: insufficient TLB flushing when using PCID [XSA-292] x86: PV kernel context switch corruption [XSA-293] x86 shadow: Insufficient TLB flushing when using PCID [XSA-294]

----

update to xen-4.10.3

----

- insufficient TLB flushing / improper large page mappings with AMD IOMMUs [XSA-275] (#1651665)

- x86: DoS from attempting to use INVPCID with a non-canonical addresses [XSA-279]

- Fix for XSA-240 conflicts with shadow paging [XSA-280]

----

guest use of HLE constructs may lock up host [XSA-282]

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora update system website.
Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected xen package.

See Also

https://bodhi.fedoraproject.org/updates/FEDORA-2019-bce6498890

Plugin Details

Severity: High

ID: 123046

File Name: fedora_2019-bce6498890.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2019/03/25

Updated: 2019/03/25

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:xen, cpe:/o:fedoraproject:fedora:28

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2019/03/21

Vulnerability Publication Date: 2018/12/08

Reference Information

CVE: CVE-2018-19961, CVE-2018-19962, CVE-2018-19963, CVE-2018-19965, CVE-2018-19966