VMware Workstation 14.x < 14.1.6 / 15.x < 15.0.3 Elevation of Privilege Vulnerability (VMSA-2019-0002)

High Nessus Plugin ID 123002

Synopsis

A virtualization application installed on the remote Windows host is affected by an elevation of privilege vulnerability.

Description

The version of VMware Workstation installed on the remote host is 14.x prior to 14.1.6 or 15.x prior to 15.0.3. It is, therefore, affected by an elevation of privilege vulnerability in the creation of the VMX process on a windows host.
An attacker with access to a host system may be able to hijack the path to the VMX executable or COM classes used by the VMX process leading to an elevation of privilege vulnerability.

Solution

Upgrade to VMware Workstation version 14.1.6, 15.0.3, or later.

See Also

https://www.vmware.com/security/advisories/VMSA-2019-0002.html

Plugin Details

Severity: High

ID: 123002

File Name: vmware_workstation_win_vmsa_2019_0002.nasl

Version: 1.8

Type: local

Family: General

Published: 2019/03/21

Updated: 2019/10/30

Dependencies: 26201, 71053

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-5512

CVSS v2.0

Base Score: 7.2

Temporal Score: 6

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 8.2

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:vmware:workstation

Required KB Items: installed_sw/VMware Workstation

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/03/14

Vulnerability Publication Date: 2019/03/14

Exploitable With

Core Impact

Reference Information

CVE: CVE-2019-5511, CVE-2019-5512

BID: 107429

VMSA: 2019-0002