GLSA-201903-16 : OpenSSH: Multiple vulnerabilities

Medium Nessus Plugin ID 122990

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201903-16 (OpenSSH: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in OpenSSH. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker could overwrite arbitrary files, transfer malicious files, or gain unauthorized access.
Workaround :

There is no known workaround at this time.

Solution

All OpenSSH users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/openssh-7.9_p1-r4'

See Also

https://security.gentoo.org/glsa/201903-16

Plugin Details

Severity: Medium

ID: 122990

File Name: gentoo_GLSA-201903-16.nasl

Version: 1.2

Type: local

Published: 2019/03/21

Updated: 2019/04/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.5

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 6.8

Temporal Score: 6.1

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:openssh, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/03/20

Vulnerability Publication Date: 2019/01/10

Reference Information

CVE: CVE-2018-20685, CVE-2019-6109, CVE-2019-6110, CVE-2019-6111

GLSA: 201903-16