Security Updates for Microsoft Sharepoint Server (March 2019)

critical Nessus Plugin ID 122859
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The Microsoft Sharepoint Server installation on the remote host is missing a security update.

Description

The Microsoft Sharepoint Server installation on the remote host is missing a security update. It is, therefore, affected by the following vulnerabilities:

- A cross-site-scripting (XSS) vulnerability exists when Microsoft SharePoint Server does not properly sanitize a specially crafted web request to an affected SharePoint server. An authenticated attacker could exploit the vulnerability by sending a specially crafted request to an affected SharePoint server. The attacker who successfully exploited the vulnerability could then perform cross-site scripting attacks on affected systems and run script in the security context of the current user. The attacks could allow the attacker to read content that the attacker is not authorized to read, use the victim's identity to take actions on the SharePoint site on behalf of the user, such as change permissions and delete content, and inject malicious content in the browser of the user. The security update addresses the vulnerability by helping to ensure that SharePoint Server properly sanitizes web requests. (CVE-2019-0778)

- A remote code execution vulnerability exists in Microsoft SharePoint when the software fails to check the source markup of an application package. An attacker who successfully exploited the vulnerability could run arbitrary code in the context of the SharePoint application pool and the SharePoint server farm account. Exploitation of this vulnerability requires that a user uploads a specially crafted SharePoint application package to an affected versions of SharePoint.(CVE-2019-0604)

Solution

Microsoft has released the following security updates to address this issue:
-KB4462184
-KB4462199
-KB4462202
-KB4462208
-KB4462211

See Also

http://www.nessus.org/u?a3eb0a95

http://www.nessus.org/u?2fa2dd75

http://www.nessus.org/u?f5d491e7

http://www.nessus.org/u?2ea0d7b4

http://www.nessus.org/u?91b3484a

Plugin Details

Severity: Critical

ID: 122859

File Name: smb_nt_ms19_mar_office_sharepoint.nasl

Version: 1.7

Type: local

Agent: windows

Published: 3/14/2019

Updated: 11/30/2021

Dependencies: microsoft_sharepoint_installed.nbin, smb_hotfixes.nasl, ms_bulletin_checks_possible.nasl

Risk Information

CVSS Score Source: CVE-2019-0604

VPR

Risk Factor: Critical

Score: 9.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:sharepoint_foundation, cpe:/a:microsoft:sharepoint_server

Required KB Items: SMB/MS_Bulletin_Checks/Possible

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/12/2019

Vulnerability Publication Date: 3/12/2019

Reference Information

CVE: CVE-2019-0604, CVE-2019-0778

BID: 106914, 107226

MSKB: 4462184, 4462199, 4462202, 4462208, 4462211, 4462217, 4462219, 4462228

MSFT: MS19-4462184, MS19-4462199, MS19-4462202, MS19-4462208, MS19-4462211, MS19-4462217, MS19-4462219, MS19-4462228