Atlassian SourceTree 0.5a < 3.0.17 Multiple remote code execution vulnerabilities

High Nessus Plugin ID 122854

Synopsis

The version of Atlassian SourceTree installed on the remote Windows host is affected by multiple remote code execution vulnerabilities.

Description

The version of Atlassian SourceTree installed on the remote Windows host is version 0.5a prior to 3.0.17. It is, therefore, affected by multiple remote code execution vulnerabilities.

- An option injection vulnerability exists in the git submodule component. An unauthenticated, remote attacker can exploit this via the processing of a recursive git clone of a project with a specially crafted .gitmodules file, to execute arbitrary commands.
(CVE-2018-17456)

- An argument injection vulnerability exists in the Mercurial repository component. An authenticated, remote attacker can exploit this via filenames in the Mercurial repositories to execute arbitrary commands. (CVE-2018-20234, CVE-2018-20235)

- A command injection vulnerability exists in the URI handling component. An unauthenticated, remote attacker could exploit this via sending a malicious URI to a victim to execution arbitrary commands. (CVE-2018-20236)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Atlassian SourceTree 3.0.17 or later.

See Also

http://www.nessus.org/u?e9103cc4

Plugin Details

Severity: High

ID: 122854

File Name: atlassian_sourcetree_3_0_17.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 2019/03/14

Updated: 2019/04/04

Dependencies: 106871

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-20236

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 8.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:atlassian:sourcetree

Required KB Items: installed_sw/SourceTree

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/03/06

Vulnerability Publication Date: 2019/03/06

Exploitable With

Metasploit (Malicious Git HTTP Server For CVE-2018-17456)

Reference Information

CVE: CVE-2018-17456, CVE-2018-20234, CVE-2018-20235, CVE-2018-20236

BID: 105523