GLSA-201903-09 : GNU C Library: Arbitrary descriptor allocation

Medium Nessus Plugin ID 122831

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201903-09 (GNU C Library: Arbitrary descriptor allocation)

A vulnerability was discovered in the GNU C Library functions xdr_bytes and xdr_string.
Impact :

A remote attacker, by sending a crafted UDP packet, could cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All GNU C Library users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=sys-libs/glibc-2.26.0'

See Also

https://security.gentoo.org/glsa/201903-09

Plugin Details

Severity: Medium

ID: 122831

File Name: gentoo_GLSA-201903-09.nasl

Version: 1.1

Type: local

Published: 2019/03/14

Updated: 2019/03/14

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:glibc, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2019/03/14

Vulnerability Publication Date: 2018/12/04

Reference Information

CVE: CVE-2018-19591

GLSA: 201903-09