Adobe Photoshop CC 19.x <= 19.1.7 / 20.x <= 20.0.2 Vulnerability (APSB19-15)

High Nessus Plugin ID 122816

Synopsis

Adobe Photoshop installed on remote macOS or Mac OS X host is affected by a vulnerability

Description

The version of Adobe Photoshop CC installed on the remote macOS or Mac OS X host is equal or prior to 19.1.7 (2018.1.7), 20.0.2 (2019.0.2). It is, therefore, affected by a vulnerability as referenced in the apsb19-15 advisory.

- Heap corruption potentially leading to Arbitrary code execution (CVE-2019-7094)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Adobe Photoshop CC version 19.1.8 (2018.1.8), 20.0.4 (2019.0.4) or later.

See Also

https://helpx.adobe.com/security/products/photoshop/apsb19-15.html

Plugin Details

Severity: High

ID: 122816

File Name: macos_adobe_photoshop_apsb19-15.nasl

Version: 1.2

Type: local

Agent: macosx

Published: 2019/03/13

Updated: 2019/03/15

Dependencies: 62220

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-7094

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:adobe:photoshop_cc

Patch Publication Date: 2019/03/12

Vulnerability Publication Date: 2019/03/12

Reference Information

CVE: CVE-2019-7094

IAVA: 2019-A-0075