Joomla! 3.x < 3.9.4 Multiple Vulnerabilities

High Nessus Plugin ID 122814


The remote web server contains a PHP application that is affected by multiple vulnerabilities.


According to its self-reported version number, the Joomla! installation running on the remote web server is prior to 3.9.4.
It is, therefore, affected by multiple vulnerabilities:

- A logic error exists in sample data plugins that allows remote attackers to gain unauthorized access to unspecified elements. (CVE-2019-9713)

- Multiple flaws exist in input-validation processes that allow an unauthenticated, remote attacker to carry out cross-site scripting (XSS) attacks. (CVE-2019-9711, CVE-2019-9712, CVE-2019-9714)

Note that Nessus has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.


Upgrade to Joomla! version 3.9.4 or later.

See Also

Plugin Details

Severity: High

ID: 122814

File Name: joomla_394.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 2019/03/13

Updated: 2019/04/18

Dependencies: 21142

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-9713

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:joomla:joomla\!

Required KB Items: installed_sw/Joomla!, www/PHP, Settings/ParanoidReport

Patch Publication Date: 2019/03/12

Vulnerability Publication Date: 2019/03/12

Reference Information

CVE: CVE-2019-9711, CVE-2019-9712, CVE-2019-9713, CVE-2019-9714