Apache < 1.3.31 / 2.0.49 Socket Connection Blocking Race Condition DoS

medium Nessus Plugin ID 12280


The remote web server is affected by a denial of service vulnerability.


The remote web server appears to be running a version of Apache that is prior to 1.3.31 / 2.0.49. It is therefore, affected by a denial of service vulnerability. A remote attacker can block new connections to the server by connecting to a listening socket on a rarely accessed port.

Note that this issue is known to affect some versions of AIX, Solaris, and Tru64 and known to not affect FreeBSD or Linux.


Upgrade to Apache 2.0.49 or 1.3.31 or later.

See Also


Plugin Details

Severity: Medium

ID: 12280

File Name: apache_conn_block.nasl

Version: 1.27

Type: remote

Family: Web Servers

Published: 6/16/2004

Updated: 6/12/2020

Risk Information


Risk Factor: Medium

Score: 4.4


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: www/apache

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 3/20/2004

Reference Information

CVE: CVE-2004-0174

BID: 9921