Apache < 1.3.31 / 2.0.49 Socket Connection Blocking Race Condition DoS

Medium Nessus Plugin ID 12280

Synopsis

The remote web server is affected by a denial of service vulnerability.

Description

The remote web server appears to be running a version of Apache that is prior to 1.3.31 / 2.0.49. It is therefore, affected by a denial of service vulnerability. A remote attacker can block new connections to the server by connecting to a listening socket on a rarely accessed port.

Note that this issue is known to affect some versions of AIX, Solaris, and Tru64 and known to not affect FreeBSD or Linux.

Solution

Upgrade to Apache 2.0.49 or 1.3.31 or later.

See Also

https://seclists.org/bugtraq/2004/Mar/191

Plugin Details

Severity: Medium

ID: 12280

File Name: apache_conn_block.nasl

Version: 1.26

Type: remote

Family: Web Servers

Published: 2004/06/16

Updated: 2018/11/15

Dependencies: 11936, 10107, 15898, 12517, 12518

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: www/apache

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2004/03/20

Reference Information

CVE: CVE-2004-0174

BID: 9921