Debian DSA-4407-1 : xmltooling - security update

High Nessus Plugin ID 122794

Synopsis

The remote Debian host is missing a security-related update.

Description

Ross Geerlings discovered that the XMLTooling library didn't correctly handle exceptions on malformed XML declarations, which could result in denial of service against the application using XMLTooling.

Solution

Upgrade the xmltooling packages.

For the stable distribution (stretch), this problem has been fixed in version 1.6.0-4+deb9u2.

See Also

https://security-tracker.debian.org/tracker/source-package/xmltooling

https://packages.debian.org/source/stretch/xmltooling

https://www.debian.org/security/2019/dsa-4407

Plugin Details

Severity: High

ID: 122794

File Name: debian_DSA-4407.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2019/03/13

Updated: 2019/03/13

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:xmltooling, cpe:/o:debian:debian_linux:9.0

Patch Publication Date: 2019/03/12

Reference Information

CVE: CVE-2019-9628

DSA: 4407