Security Update for .NET Core SDK (March 2019)

medium Nessus Plugin ID 122778

Synopsis

The remote Windows host is affected by a tampering vulnerability.

Description

The remote Windows host has an installation of .NET Core SDK with a version of 1.x < 1.1.13 or 2.1.x < 2.1.505. Therefore, the host is affected by a tampering vulnerability with in the NuGet Package Manager. An authenticated, attacker can exploit this, via manipulating the folder contents prior to building or installing a application, to modify files and folders after unpacking.

Solution

Refer to vendor documentation.

See Also

https://github.com/dotnet/announcements/issues/103

http://www.nessus.org/u?8b5a86c1

http://www.nessus.org/u?0225f3cc

http://www.nessus.org/u?7c0a5e95

Plugin Details

Severity: Medium

ID: 122778

File Name: smb_nt_ms19_mar_dotnet_core_sdk.nasl

Version: 1.4

Type: local

Agent: windows

Family: Windows

Published: 3/12/2019

Updated: 1/17/2020

Supported Sensors: Nessus Agent

Risk Information

CVSS Score Source: CVE-2019-0757

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: AV:N/AC:L/Au:S/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:microsoft:.net_core

Required KB Items: installed_sw/.NET Core SDK Windows

Exploit Ease: No known exploits are available

Patch Publication Date: 3/12/2019

Vulnerability Publication Date: 3/12/2019

Reference Information

CVE: CVE-2019-0757