Palo Alto Networks 7.1.x < 7.1.22 / 8.0.x < 8.0.15 / 8.1.x < 8.1.6 Cross-Site Scripting Vulnerability (PAN-SA-2019-0001)

medium Nessus Plugin ID 122757

Synopsis

The remote host is affected by cross-site scripting (XSS) vulnerability that exists in the PAN-OS external dynamic lists.

Description

The version of Palo Alto Networks PAN-OS running on the remote host is 7.1.x prior to 7.1.22 or 8.0.x prior to 8.0.15 or 8.1.x prior to 8.1.6. It is, therefore, affected by a cross-site scripting (XSS) vulnerability that exists in the PAN-OS external dynamic lists due to improper validation of user-supplied input before returning it to users. An authenticated, remote attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session.
(CVE-2019-1565)

Solution

Upgrade to Palo Alto Networks PAN-OS version 7.1.22 / 8.0.15 / 8.1.6 or later.

See Also

http://www.nessus.org/u?eabcce9b

Plugin Details

Severity: Medium

ID: 122757

File Name: palo_alto_PAN-SA-2019-0001.nasl

Version: 1.5

Type: combined

Published: 3/12/2019

Updated: 4/1/2021

Risk Information

VPR

Risk Factor: Low

Score: 3

CVSS v2

Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: AV:N/AC:M/Au:S/C:N/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2019-1565

CVSS v3

Risk Factor: Medium

Base Score: 5.4

Temporal Score: 4.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/o:paloaltonetworks:pan-os

Required KB Items: Host/Palo_Alto/Firewall/Version, Host/Palo_Alto/Firewall/Full_Version, Host/Palo_Alto/Firewall/Source

Exploit Ease: No known exploits are available

Patch Publication Date: 1/23/2019

Vulnerability Publication Date: 1/23/2019

Reference Information

CVE: CVE-2019-1565

BID: 106752