Ubuntu 18.04 LTS : linux-hwe, linux-azure vulnerabilities (USN-3903-2)

Medium Nessus Plugin ID 122669

Synopsis

The remote Ubuntu host is missing one or more security-related patches.

Description

USN-3903-1 fixed vulnerabilities in the Linux kernel for Ubuntu 18.10.
This update provides the corresponding updates for the Linux Hardware Enablement (HWE) kernel from Ubuntu 18.10 for Ubuntu 18.04 LTS.

Jason Wang discovered that the vhost net driver in the Linux kernel contained an out of bounds write vulnerability. An attacker in a guest virtual machine could use this to cause a denial of service (host system crash) or possibly execute arbitrary code in the host kernel.
(CVE-2018-16880)

Jann Horn discovered that the userfaultd implementation in the Linux kernel did not properly restrict access to certain ioctls. A local attacker could use this possibly to modify files. (CVE-2018-18397)

Jann Horn discovered a race condition in the fork() system call in the Linux kernel. A local attacker could use this to gain access to services that cache authorizations. (CVE-2019-6133).

Note that Tenable Network Security has extracted the preceding description block directly from the Ubuntu security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected packages.

See Also

https://usn.ubuntu.com/3903-2/

Plugin Details

Severity: Medium

ID: 122669

File Name: ubuntu_USN-3903-2.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2019/03/07

Updated: 2019/09/18

Dependencies: 12634, 122878

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.9

Temporal Score: 5.4

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 7

Temporal Score: 6.3

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:canonical:ubuntu_linux:linux-image-4.18-azure, p-cpe:/a:canonical:ubuntu_linux:linux-image-4.18-generic, p-cpe:/a:canonical:ubuntu_linux:linux-image-4.18-generic-lpae, p-cpe:/a:canonical:ubuntu_linux:linux-image-4.18-lowlatency, p-cpe:/a:canonical:ubuntu_linux:linux-image-4.18-snapdragon, p-cpe:/a:canonical:ubuntu_linux:linux-image-azure, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-hwe-18.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-generic-lpae-hwe-18.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-lowlatency-hwe-18.04, p-cpe:/a:canonical:ubuntu_linux:linux-image-snapdragon-hwe-18.04, cpe:/o:canonical:ubuntu_linux:18.04:-:lts

Required KB Items: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/03/06

Vulnerability Publication Date: 2018/12/12

Reference Information

CVE: CVE-2018-16880, CVE-2018-18397, CVE-2019-6133

USN: 3903-2