nginx <= 1.3.13 Insecure Log Permissions

High Nessus Plugin ID 122612


The remote web server is affected by an information disclosure vulnerability.


According to its Server response header, the installed version of nginx is prior to or equal to 1.3.13. It is, therefore, affected by a flaw related to creating and handling log files that allows information disclosure due to insecure filesystem permissions.


Upgrade to nginx 1.3.14 or later.

See Also

Plugin Details

Severity: High

ID: 122612

File Name: nginx_CVE-2013-0337.nasl

Version: 1.2

Type: remote

Family: Web Servers

Published: 2019/03/05

Updated: 2019/03/27

Dependencies: 106375

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2013-0337

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

CVSS v3.0

Base Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Required KB Items: Settings/ParanoidReport, installed_sw/nginx

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/02/21

Vulnerability Publication Date: 2013/02/21

Reference Information

CVE: CVE-2013-0337

BID: 58105