Subversion < 1.0.4 Pre-Commit-Hook Remote Overflow

High Nessus Plugin ID 12260


The remote service is vulnerable to a buffer overflow.


The remote host is reported vulnerable to a remote overflow. An attacker, exploiting this hole, would be given full access to the target machine. Versions of Subversion less than 1.0.4 are vulnerable to this attack.


Upgrade to version 1.0.4 or higher

See Also

Plugin Details

Severity: High

ID: 12260

File Name: subversion_1_0_3.nasl

Version: $Revision: 1.13 $

Type: remote

Family: Misc.

Published: 2004/06/08

Modified: 2016/12/14

Dependencies: 12259

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:U/RC:C

Vulnerability Information

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2004/05/21

Reference Information

BID: 10428

OSVDB: 38192