PHP 5.6.x < 5.6.35 Security Bypass Vulnerability

Low Nessus Plugin ID 122591

Synopsis

The version of PHP running on the remote web server is affected by a security bypass vulnerability.

Description

According to its banner, the version of PHP running on the remote web server is 5.6.x prior to 5.6.35. It is, therefore, affected by a security bypass vulnerability. Dumpable FPM child processes allow bypassing opcache access controls because fpm_unix.c makes a PR_SET_DUMPABLE prctl call, allowing one user (in a multiuser environment) to obtain sensitive information from the process memory of a second user's PHP applications by running gcore on the PID of the PHP-FPM worker process.

Solution

Upgrade to PHP version 5.6.35 or later.

See Also

http://php.net/ChangeLog-5.php#5.6.35

Plugin Details

Severity: Low

ID: 122591

File Name: php_5_6_35.nasl

Version: 1.2

Type: remote

Family: CGI abuses

Published: 2019/03/04

Updated: 2019/10/31

Dependencies: 48243

Risk Information

Risk Factor: Low

CVSS Score Source: CVE-2018-10545

CVSS v2.0

Base Score: 1.9

Temporal Score: 1.4

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 4.7

Temporal Score: 4.1

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/03/29

Vulnerability Publication Date: 2018/03/29

Reference Information

CVE: CVE-2018-10545

BID: 104022