PHP 5.4.x < 5.4.0 Multiple Vulnerabilities

high Nessus Plugin ID 122590

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP installed on the remote host is 5.4.x earlier than 5.4.0, and, therefore, potentially affected by multiple vulnerabilities :

- crypt_blowfish as used in PHP does not properly handle 8-bit characters, which makes it easier for context-dependent attackers to determine a cleartext password by leveraging knowledge of a password hash.
(CVE-2011-2483)

- Multiple NULL Pointer Dereference with the zend_strndup() fucntion could allow a remote attacker to cause a denial of service. (CVE-2011-4153)

- A flaw in SSL sockets with SSL 3.0 / TLS 1.0 was addressed. (CVE-2011-3389)

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 5.4.0 or later.

See Also

https://bugs.php.net/bug.php?id=55748

http://www.php.net/ChangeLog-5.php#5.4.0

http://php.net/releases/5_4_0.php

Plugin Details

Severity: High

ID: 122590

File Name: php_5_4_0.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 3/4/2019

Updated: 4/11/2022

Risk Information

CVSS Score Source: CVE-2011-2483

VPR

Risk Factor: Medium

Score: 6.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.3

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:H/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 7.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 3/1/2012

Vulnerability Publication Date: 3/1/2012

Reference Information

CVE: CVE-2011-2483, CVE-2011-3389, CVE-2011-4153

BID: 49241, 49778, 51417