Mac OS X < 10.3.4 Multiple Vulnerabilities

Critical Nessus Plugin ID 12257

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 8.9

Synopsis

The remote host is missing a Mac OS X update that fixes a security issue.

Description

The remote host is running a version of Mac OS X that is older than 10.3.4. Such versions contain several flaws that may allow an attacker to execute arbitrary commands on the remote system with root privileges.

Solution

Upgrade to Mac OS X 10.3.4 or later.

See Also

http://support.apple.com/kb/HT1646

http://lists.apple.com/archives/security-announce/2004/May/msg00005.html

Plugin Details

Severity: Critical

ID: 12257

File Name: macosx_multiple_vulns.nasl

Version: 1.27

Type: combined

Agent: macosx

Published: 2004/06/01

Updated: 2018/07/14

Dependencies: 11936

Risk Information

Risk Factor: Critical

VPR Score: 8.9

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

Required KB Items: Host/OS

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2004/05/28

Vulnerability Publication Date: 2004/05/03

Exploitable With

Metasploit (AppleFileServer LoginExt PathName Overflow)

Reference Information

CVE: CVE-2004-0171, CVE-2004-0430, CVE-2004-0485, CVE-2004-0513, CVE-2004-0514, CVE-2004-0515, CVE-2004-0516, CVE-2004-0517, CVE-2004-0518

BID: 10268, 10271, 10432