Debian DLA-1696-1 : ceph security update

Low Nessus Plugin ID 122547

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 4.4

Synopsis

The remote Debian host is missing a security update.

Description

Several vulnerabilities were discovered in Ceph, a distributed storage and file system.

CVE-2018-14662

It was found that authenticated ceph users with read only permissions could steal dm-crypt encryption keys used in ceph disk encryption.

CVE-2018-16846

It was found that authenticated ceph RGW users can cause a denial of service against OMAPs holding bucket indices.

For Debian 8 'Jessie', these problems have been fixed in version 0.80.7-2+deb8u3.

We recommend that you upgrade your ceph packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2019/03/msg00002.html

https://packages.debian.org/source/jessie/ceph

Plugin Details

Severity: Low

ID: 122547

File Name: debian_DLA-1696.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2019/03/04

Updated: 2021/01/11

Dependencies: 12634

Risk Information

Risk Factor: Low

VPR Score: 4.4

CVSS Score Source: CVE-2018-14662

CVSS v2.0

Base Score: 2.7

Temporal Score: 2

Vector: CVSS2#AV:A/AC:L/Au:S/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.7

Temporal Score: 5

Vector: CVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ceph, p-cpe:/a:debian:debian_linux:ceph-common, p-cpe:/a:debian:debian_linux:ceph-common-dbg, p-cpe:/a:debian:debian_linux:ceph-dbg, p-cpe:/a:debian:debian_linux:ceph-fs-common, p-cpe:/a:debian:debian_linux:ceph-fs-common-dbg, p-cpe:/a:debian:debian_linux:ceph-fuse, p-cpe:/a:debian:debian_linux:ceph-fuse-dbg, p-cpe:/a:debian:debian_linux:ceph-mds, p-cpe:/a:debian:debian_linux:ceph-mds-dbg, p-cpe:/a:debian:debian_linux:ceph-resource-agents, p-cpe:/a:debian:debian_linux:ceph-test, p-cpe:/a:debian:debian_linux:ceph-test-dbg, p-cpe:/a:debian:debian_linux:libcephfs-dev, p-cpe:/a:debian:debian_linux:libcephfs-java, p-cpe:/a:debian:debian_linux:libcephfs-jni, p-cpe:/a:debian:debian_linux:libcephfs-jni-dbg, p-cpe:/a:debian:debian_linux:libcephfs1, p-cpe:/a:debian:debian_linux:libcephfs1-dbg, p-cpe:/a:debian:debian_linux:librados-dev, p-cpe:/a:debian:debian_linux:librados2, p-cpe:/a:debian:debian_linux:librados2-dbg, p-cpe:/a:debian:debian_linux:librbd-dev, p-cpe:/a:debian:debian_linux:librbd1, p-cpe:/a:debian:debian_linux:librbd1-dbg, p-cpe:/a:debian:debian_linux:python-ceph, p-cpe:/a:debian:debian_linux:radosgw, p-cpe:/a:debian:debian_linux:radosgw-dbg, p-cpe:/a:debian:debian_linux:rbd-fuse, p-cpe:/a:debian:debian_linux:rbd-fuse-dbg, p-cpe:/a:debian:debian_linux:rest-bench, p-cpe:/a:debian:debian_linux:rest-bench-dbg, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Ease: No known exploits are available

Patch Publication Date: 2019/03/01

Vulnerability Publication Date: 2019/01/15

Reference Information

CVE: CVE-2018-14662, CVE-2018-16846