PHP 7.0.x < 7.0.17 Denial of Service Vulnerability

high Nessus Plugin ID 122537


The version of PHP running on the remote web server is affected by a denial of service vulnerability.


According to its banner, the version of PHP running on the remote web server is 7.0.x prior to 7.0.17. It is, therefore, affected by a denial of service condition in PHP when handling overlarge POST requests. An unauthenticated, remote attacker can exploit this to exhaust available CPU resources.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to PHP version 7.0.17 or later.

See Also

Plugin Details

Severity: High

ID: 122537

File Name: php_7_0_17.nasl

Version: 1.3

Type: remote

Family: CGI abuses

Published: 3/1/2019

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information


Risk Factor: Low

Score: 3.6


Risk Factor: High

Base Score: 7.8

Temporal Score: 5.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2017-11142


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No known exploits are available

Patch Publication Date: 3/16/2017

Vulnerability Publication Date: 3/16/2017

Reference Information

CVE: CVE-2017-11142

BID: 99601