OpenSSL 1.0.x < 1.0.2r Information Disclosure Vulnerability

Medium Nessus Plugin ID 122504

Synopsis

A service running on the remote host is affected by an information disclosure vulnerability.

Description

According to its banner, the version of OpenSSL running on the remote host is 1.0.x prior to 1.0.2r. It is, therefore, affected by an information disclosure vulnerability due to the decipherable way a application responds to a 0 byte record. An unauthenticated, remote attacker could exploit this vulnerability, via a padding oracle attack, to potentially disclose sensitive information.

Note: Only 'non-stitched' ciphersuites are exploitable.

Solution

Upgrade to OpenSSL version 1.0.2r or later.

See Also

http://www.nessus.org/u?0e8c6acd

https://www.openssl.org/news/secadv/20190226.txt

Plugin Details

Severity: Medium

ID: 122504

File Name: openssl_1_0_2r.nasl

Version: 1.1

Type: remote

Family: Web Servers

Published: 2019/03/01

Updated: 2019/03/01

Dependencies: 57323

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-1559

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Patch Publication Date: 2019/02/26

Vulnerability Publication Date: 2019/02/26

Reference Information

CVE: CVE-2019-1559

BID: 107174

IAVA: 2019-A-0064