Drupal Remote Code Execution Vulnerability (SA-CORE-2019-003) (exploit)

high Nessus Plugin ID 122449
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server hosts a PHP CMS that is affected by a remote command execution vulnerability.

Description

The Drupal CMS installed on the remote host is affected by a remote command execution vulnerability. A remote, unauthenticated attacker can leverage this issue to execute arbitrary commands on the remote host.

Solution

Upgrade to Drupal version 8.5.11 / 8.6.10 or later.

See Also

https://www.drupal.org/SA-CORE-2019-003

https://www.ambionics.io/blog/drupal8-rce

https://mp.weixin.qq.com/s/EQD4-K6HgBY9wdzeXeyzkg

Plugin Details

Severity: High

ID: 122449

File Name: drupal_CVE-2019-6340_rce.nbin

Version: 1.35

Type: remote

Family: CGI abuses

Published: 2/27/2019

Updated: 7/22/2021

Dependencies: drupal_detect.nasl

Risk Information

CVSS Score Source: CVE-2019-6340

VPR

Risk Factor: Critical

Score: 9.2

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.6

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal

Exploit Available: true

Exploit Ease: Exploits are available

Exploited by Nessus: true

Patch Publication Date: 2/20/2019

Vulnerability Publication Date: 2/20/2019

Exploitable With

CANVAS (CANVAS)

Core Impact

Metasploit (Drupal RESTful Web Services unserialize() RCE)

Reference Information

CVE: CVE-2019-6340

BID: 107106