Drupal 8.5.x < 8.5.11 / 8.6.x < 8.6.10 Remote Code Execution (SA-CORE-2019-003)

high Nessus Plugin ID 122349
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


A PHP application running on the remote web server is affected by a remote code execution vulnerability.


According to its self-reported version, the instance of Drupal running on the remote web server is 8.5.x prior to 8.5.11, or 8.6.x prior to 8.6.10. It is, therefore, affected by a remote code execution vulnerability due to improper sanitization of data from non-form sources.


Upgrade to Drupal version 8.5.11 / 8.6.10 or later.

See Also




Plugin Details

Severity: High

ID: 122349

File Name: drupal_8_6_10.nasl

Version: 1.9

Type: remote

Family: CGI abuses

Published: 2/20/2019

Updated: 10/31/2019

Dependencies: drupal_detect.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2019-6340


Risk Factor: Critical

Score: 9.2


Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.6

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:F/RL:OF/RC:C


Risk Factor: High

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2/20/2019

Vulnerability Publication Date: 2/20/2019

Exploitable With


Core Impact

Metasploit (Drupal RESTful Web Services unserialize() RCE)

Reference Information

CVE: CVE-2019-6340