Drupal 8.5.x < 8.5.11 / 8.6.x < 8.6.10 Remote Code Execution (SA-CORE-2019-003)

High Nessus Plugin ID 122349

Synopsis

A PHP application running on the remote web server is affected by a remote code execution vulnerability.

Description

According to its self-reported version, the instance of Drupal running on the remote web server is 8.5.x prior to 8.5.11, or 8.6.x prior to 8.6.10. It is, therefore, affected by a remote code execution vulnerability due to improper sanitization of data from non-form sources.

Solution

Upgrade to Drupal version 8.5.11 / 8.6.10 or later.

See Also

https://www.drupal.org/sa-core-2019-003

https://www.drupal.org/project/drupal/releases/8.5.11

https://www.drupal.org/project/drupal/releases/8.6.10

Plugin Details

Severity: High

ID: 122349

File Name: drupal_8_6_10.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 2019/02/20

Updated: 2019/04/16

Dependencies: 18638

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-6340

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/02/20

Vulnerability Publication Date: 2019/02/20

Exploitable With

CANVAS (CANVAS)

Metasploit (Drupal RESTful Web Services unserialize() RCE)

Reference Information

CVE: CVE-2019-6340