Exim < 3.36 / 4.33 Multiple Remote Overflows

Medium Nessus Plugin ID 12232


The remote SMTP server has multiple buffer overflow vulnerabilities.


The remote version of Exim has multiple remote stack-based buffer overflow vulnerabilities when header syntax checking is enabled. It should be noted that this is not the default configuration. A remote attacker could exploit this to execute arbitrary code.


Upgrade to Exim 4.32 or later, or disable header syntax checking in exim.conf.

See Also


Plugin Details

Severity: Medium

ID: 12232

File Name: exim_mult_overflow.nasl

Version: $Revision: 1.21 $

Type: remote

Published: 2004/05/06

Modified: 2016/10/10

Dependencies: 10263

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: cpe:/a:exim:exim

Required KB Items: Settings/ParanoidReport

Vulnerability Publication Date: 2004/05/06

Reference Information

CVE: CVE-2004-0399, CVE-2004-0400

OSVDB: 5896, 5897

Secunia: 11558