Apache 2.4.17 / 2.4.18 DoS

Medium Nessus Plugin ID 122059


The remote web server is affected by a denial of service vulnerability.


According to its banner, the version of Apache running on the remote host is either 2.4.17 or 2.4.18.

A denial of service (DoS) vulnerability exists in server threads due to a lengthy thread-block time. An unauthenticated, remote attacker can exploit this issue, to block server threads, and causing the application to stop responding.


Upgrade to Apache version 2.4.20 or later.

See Also



Plugin Details

Severity: Medium

ID: 122059

File Name: apache_2_4_20.nasl

Version: 1.2

Type: remote

Family: Web Servers

Published: 2019/02/08

Updated: 2019/10/31

Dependencies: 48204, 84821

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2016-1546

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5.9

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/04/11

Vulnerability Publication Date: 2016/04/11

Reference Information

CVE: CVE-2016-1546

BID: 92331