Samba < 3.4.0 Remote Code Execution Vulnerability

High Nessus Plugin ID 122058

Synopsis

The remote Samba server is affected by a remote code execution vulnerability.

Description

The version of Samba running on the remote host is prior to
3.4.0. It is, therefore, affected by a remote code execution
vulnerability in process.c due to a heap-based buffer overflow. An
unauthenticated, remote attacker can exploit this to bypass authentication
and execute arbitrary commands via Batched / AndX request.

Note that Nessus has not tested for this issue but has instead relied
only on the application's self-reported version number.

Solution

Upgrade to Samba version 3.4.0 or later.

See Also

https://www.samba.org/samba/security/CVE-2012-0870.html

Plugin Details

Severity: High

ID: 122058

File Name: samba_3_4_0.nasl

Version: 1.1

Type: remote

Family: Misc.

Published: 2019/02/08

Modified: 2019/02/08

Dependencies: 10785

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2012-0870

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2008/08/26

Vulnerability Publication Date: 2008/08/22

Reference Information

CVE: CVE-2012-0870

BID: 52103