Samba < 3.4.0 Remote Code Execution Vulnerability

High Nessus Plugin ID 122058


The remote Samba server is affected by a remote code execution vulnerability.


The version of Samba running on the remote host is prior to 3.4.0. It is, therefore, affected by a remote code execution vulnerability in process.c due to a heap-based buffer overflow. An unauthenticated, remote attacker can exploit this to bypass authentication and execute arbitrary commands via Batched / AndX request.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.


Upgrade to Samba version 3.4.0 or later.

See Also

Plugin Details

Severity: High

ID: 122058

File Name: samba_3_4_0.nasl

Version: 1.3

Type: remote

Family: Misc.

Published: 2019/02/08

Updated: 2019/10/31

Dependencies: 10785

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2012-0870

CVSS v2.0

Base Score: 7.9

Temporal Score: 5.8

Vector: CVSS2#AV:A/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2008/08/26

Vulnerability Publication Date: 2008/08/22

Reference Information

CVE: CVE-2012-0870

BID: 52103