Debian DLA-1668-1 : libarchive security update

Medium Nessus Plugin ID 122038

Synopsis

The remote Debian host is missing a security update.

Description

Fuzzing found two further file-format specific issues in libarchive, a
read-only segfault in 7z, and an infinite loop in ISO9660.

CVE-2019-1000019

Out-of-bounds Read vulnerability in 7zip decompression, that can
result in a crash (denial of service, CWE-125) CVE-2019-1000020

Vulnerability in ISO9660 parser that can result in DoS by
infinite loop (CWE-835)

For Debian 8 'Jessie', these problems have been fixed in version
3.1.2-11+deb8u7.

We recommend that you upgrade your libarchive packages.

NOTE: Tenable Network Security has extracted the preceding description
block directly from the DLA security advisory. Tenable has attempted
to automatically clean and format it as much as possible without
introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2019/02/msg00013.html

https://packages.debian.org/source/jessie/libarchive

Plugin Details

Severity: Medium

ID: 122038

File Name: debian_DLA-1668.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2019/02/08

Modified: 2019/02/08

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:bsdcpio, p-cpe:/a:debian:debian_linux:bsdtar, p-cpe:/a:debian:debian_linux:libarchive-dev, p-cpe:/a:debian:debian_linux:libarchive13, cpe:/o:debian:debian_linux:8.0

Patch Publication Date: 2019/02/07

Vulnerability Publication Date: 2019/02/04

Reference Information

CVE: CVE-2019-1000019, CVE-2019-1000020