Photon OS 2.0: Ruby PHSA-2018-2.0-0011-(a)

High Nessus Plugin ID 121908

Synopsis

The remote PhotonOS host is missing multiple security updates.

Description

An update of the ruby package has been released.

Solution

Update the affected Linux packages.

See Also

https://github.com/vmware/photon/wiki/Security-Updates-2-11-a.md

Plugin Details

Severity: High

ID: 121908

File Name: PhotonOS_PHSA-2018-2_0-0011-a_ruby.nasl

Version: 1.2

Type: local

Published: 2019/02/07

Updated: 2019/04/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2017-16997

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 7.8

Temporal Score: 7

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:vmware:photonos:ruby, cpe:/o:vmware:photonos:2.0

Required KB Items: Host/local_checks_enabled, Host/PhotonOS/release, Host/PhotonOS/rpm-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/01/11

Vulnerability Publication Date: 2018/01/11

Reference Information

CVE: CVE-2017-17405