Debian DSA-4384-1 : libgd2 - security update

High Nessus Plugin ID 121576

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple vulnerabilities have been discovered in libgd2, a library for programmatic graphics creation and manipulation, which may result in denial of service or potentially the execution of arbitrary code if a malformed file is processed.

Solution

Upgrade the libgd2 packages.

For the stable distribution (stretch), these problems have been fixed in version 2.2.4-2+deb9u4.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=920645

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=920728

https://security-tracker.debian.org/tracker/source-package/libgd2

https://packages.debian.org/source/stretch/libgd2

https://www.debian.org/security/2019/dsa-4384

Plugin Details

Severity: High

ID: 121576

File Name: debian_DSA-4384.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2019/02/05

Updated: 2019/04/10

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libgd2, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/02/04

Vulnerability Publication Date: 2019/01/26

Reference Information

CVE: CVE-2019-6977, CVE-2019-6978

DSA: 4384