OpenSSL 1.0.x < 1.0.2q Multiple Vulnerabilities

medium Nessus Plugin ID 121383
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

A service running on the remote host is affected by multiple vulnerabilities.

Description

According to its banner, the version of OpenSSL running on the remote host is 1.0.x prior to 1.0.2q. It is, therefore, affected by a denial of service vulnerability and a cache timing side channel vulnerability.

Solution

Upgrade to OpenSSL version 1.0.2q or later.

See Also

https://www.openssl.org/news/secadv/20181112.txt

https://www.openssl.org/news/secadv/20181030.txt

Plugin Details

Severity: Medium

ID: 121383

File Name: openssl_1_0_2q.nasl

Version: 1.2

Type: remote

Family: Web Servers

Published: 1/25/2019

Updated: 4/2/2019

Dependencies: openssl_version.nasl

Risk Information

CVSS Score Source: CVE-2018-0734

VPR

Risk Factor: Medium

Score: 5.1

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.4

Vector: AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 11/20/2018

Vulnerability Publication Date: 10/30/2018

Reference Information

CVE: CVE-2018-5407, CVE-2018-0734

BID: 105758, 105897