Apache 2.4.x < 2.4.38 Multiple Vulnerabilities

Medium Nessus Plugin ID 121355

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

According to its banner, the version of Apache running on the remote host is 2.4.x prior to 2.4.38. It is, therefore, affected by multiple vulnerabilities:

- A denial of service (DoS) vulnerability exists in HTTP/2 steam handling. An unauthenticated, remote attacker can exploit this issue, via sending request bodies in a slow loris way to plain resources, to occupy a server thread. (CVE-2018-17189)

- A vulnerability exists in mod_sesion_cookie, as it does not properly check the expiry time of cookies. (CVE-2018-17199)

- A denial of service (DoS) vulnerability exists in mod_ssl when used with OpenSSL 1.1.1 due to an interaction in changes to handling of renegotiation attempts. An unauthenticated, remote attacker can exploit this issue to cause mod_ssl to stop responding. (CVE-2019-0190)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache version 2.4.38 or later.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.38

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.38

Plugin Details

Severity: Medium

ID: 121355

File Name: apache_2_4_38.nasl

Version: 1.2

Type: remote

Family: Web Servers

Published: 2019/01/24

Updated: 2019/04/05

Dependencies: 48204

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2019-0190

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:apache:http_server, cpe:/a:apache:httpd

Required KB Items: installed_sw/Apache

Patch Publication Date: 2019/01/22

Vulnerability Publication Date: 2019/01/22

Reference Information

CVE: CVE-2018-17189, CVE-2018-17199, CVE-2019-0190