Network Time Protocol Daemon (ntpd) 3.x / 4.x < 4.2.8p3 Denial Of Service Vulnerability

medium Nessus Plugin ID 121310
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote NTP server is affected by a denial of service vulnerability.

Description

The version of the remote NTP server is 3.x or 4.x prior to 4.2.8p3.
It is, therefore, affected by the following vulnerability :

- ntpd in ntp before 4.2.8p3 with remote configuration enabled allows remote authenticated users with knowledge of the configuration password and access to a computer entrusted to perform remote configuration to cause a denial of service (service crash) via a NULL byte in a crafted configuration directive packet. (CVE-2015-1798)

Solution

Upgrade to NTP version 4.2.8p3 or later.

See Also

http://support.ntp.org/bin/view/Main/SecurityNotice

http://bugs.ntp.org/show_bug.cgi?id=2853

Plugin Details

Severity: Medium

ID: 121310

File Name: ntp_4_2_8p3.nasl

Version: 1.2

Type: remote

Family: Misc.

Published: 1/22/2019

Updated: 10/31/2019

Dependencies: ntp_open.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2015-5146

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Low

Base Score: 3.5

Temporal Score: 2.6

Vector: AV:N/AC:M/Au:S/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ntp:ntp

Required KB Items: NTP/Running, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 6/29/2015

Vulnerability Publication Date: 6/16/2015

Reference Information

CVE: CVE-2015-5146