Drupal 7.x < 7.62 / 8.5.x < 8.5.9 / 8.6.x < 8.6.6 Multiple Vulnerabilities (SA-CORE-2019-001, SA-CORE-2019-002)

High Nessus Plugin ID 121214

Synopsis

A PHP application running on the remote web server is affected by multiple vulnerabilities.

Description

According to its self-reported version, the instance of Drupal running on the remote web server is 7.x prior to 7.62, 8.5.x prior to 8.5.9, or 8.6.x prior to 8.6.6. It is, therefore, affected by multiple phar handling vulnerabilities. An unauthenticated attacker could leverage these vulnerabilities to potentially perform remote code execution attacks and gain access in the context the web server user.

Solution

Upgrade to Drupal version 7.60 / 8.5.8 / 8.6.2 or later.

See Also

https://www.drupal.org/sa-core-2019-001

https://www.drupal.org/sa-core-2019-002

https://www.drupal.org/project/drupal/releases/7.62

https://www.drupal.org/project/drupal/releases/8.5.9

https://www.drupal.org/project/drupal/releases/8.6.6

Plugin Details

Severity: High

ID: 121214

File Name: drupal_8_6_6.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 2019/01/16

Updated: 2019/04/02

Dependencies: 18638

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2019-1000888

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2019/01/16

Vulnerability Publication Date: 2019/01/16

Reference Information

CVE: CVE-2018-1000888, CVE-2019-6338, CVE-2019-6339

BID: 106647, 106664, 106706

EDB-ID: 46108