Drupal 7.x < 7.62 / 8.5.x < 8.5.9 / 8.6.x < 8.6.6 Multiple Vulnerabilities (SA-CORE-2019-001, SA-CORE-2019-002)

critical Nessus Plugin ID 121214
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


A PHP application running on the remote web server is affected by multiple vulnerabilities.


According to its self-reported version, the instance of Drupal running on the remote web server is 7.x prior to 7.62, 8.5.x prior to 8.5.9, or 8.6.x prior to 8.6.6. It is, therefore, affected by multiple phar handling vulnerabilities. An unauthenticated attacker could leverage these vulnerabilities to potentially perform remote code execution attacks and gain access in the context the web server user.


Upgrade to Drupal version 7.60 / 8.5.8 / 8.6.2 or later.

See Also






Plugin Details

Severity: Critical

ID: 121214

File Name: drupal_8_6_6.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 1/16/2019

Updated: 10/31/2019

Dependencies: drupal_detect.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2019-6339


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C


Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:drupal:drupal

Required KB Items: installed_sw/Drupal, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/16/2019

Vulnerability Publication Date: 1/16/2019

Reference Information

CVE: CVE-2018-1000888, CVE-2019-6338, CVE-2019-6339

BID: 106647, 106664, 106706

EDB-ID: 46108