Debian DSA-4367-1 : systemd - security update

high Nessus Plugin ID 121136

Synopsis

The remote Debian host is missing a security-related update.

Description

The Qualys Research Labs discovered multiple vulnerabilities in systemd-journald. Two memory corruption flaws, via attacker-controlled allocations using the alloca function (CVE-2018-16864, CVE-2018-16865 ) and an out-of-bounds read flaw leading to an information leak (CVE-2018-16866 ), could allow an attacker to cause a denial of service or the execution of arbitrary code.

Further details in the Qualys Security Advisory at https://www.qualys.com/2019/01/09/system-down/system-down.txt

Solution

Upgrade the systemd packages.

For the stable distribution (stretch), these problems have been fixed in version 232-25+deb9u7.

See Also

https://security-tracker.debian.org/tracker/source-package/systemd

https://packages.debian.org/source/stretch/systemd

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=918841

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=918848

https://security-tracker.debian.org/tracker/CVE-2018-16864

https://security-tracker.debian.org/tracker/CVE-2018-16865

https://security-tracker.debian.org/tracker/CVE-2018-16866

https://www.qualys.com/2019/01/09/system-down/system-down.txt

https://www.debian.org/security/2019/dsa-4367

Plugin Details

Severity: High

ID: 121136

File Name: debian_DSA-4367.nasl

Version: 1.4

Type: local

Agent: unix

Published: 1/14/2019

Updated: 5/17/2019

Supported Sensors: Frictionless Assessment Agent, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Medium

Base Score: 4.6

Temporal Score: 3.6

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.8

Temporal Score: 7

Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*, p-cpe:2.3:a:debian:debian_linux:systemd:*:*:*:*:*:*:*

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 1/13/2019

Vulnerability Publication Date: 1/11/2019

Reference Information

CVE: CVE-2018-16864, CVE-2018-16865, CVE-2018-16866

DSA: 4367