Apache Tomcat < 8.0.0-RC10 Multiple Vulnerabilities

Medium Nessus Plugin ID 121122

Synopsis

The remote Apache Tomcat server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the Apache Tomcat instance listening on the remote host is prior to 8.0.0-RC10. It is, therefore, affected by multiple vulnerabilities:

- The fix for CVE-2012-3544 was not complete and limits are not properly applied to chunk extensions and whitespaces in certain trailing headers. This error could allow denial of service attacks. (CVE-2013-4322)

- The application allows XML External Entity (XXE) processing that could disclose sensitive information.
(CVE-2013-4590)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 8.0.0-RC10 or later.

See Also

http://www.nessus.org/u?4ce2c587

Plugin Details

Severity: Medium

ID: 121122

File Name: tomcat_8_0_0_rc10.nasl

Version: 1.1

Type: remote

Family: Web Servers

Published: 2019/01/11

Updated: 2019/01/11

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2013-4590

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 3.7

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Patch Publication Date: 2013/12/26

Vulnerability Publication Date: 2013/06/12

Reference Information

CVE: CVE-2013-4322, CVE-2013-4590