Apache Tomcat 7.0.x < 7.0.88 Denial of Service

Medium Nessus Plugin ID 121121


The remote Apache Tomcat server is affected by a denial of service vulnerability.


According to its self-reported version number, the Apache Tomcat instance listening on the remote host is 7.0.x prior to 7.0.88.
It is, therefore, affected by the following vulnerability:

- A denial of service (DoS) vulnerability exists in Tomcat due to improper overflow handling in the UTF-8 decoder. An unauthenticated, remote attacker can exploit this issue to cause an infinite loop in the decoder, leading to a denial of service condition.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat version 7.0.88 or later.

See Also


Plugin Details

Severity: Medium

ID: 121121

File Name: tomcat_7_0_88.nasl

Version: 1.1

Type: remote

Family: Web Servers

Published: 2019/01/11

Updated: 2019/01/11

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-1336

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Patch Publication Date: 2018/05/16

Vulnerability Publication Date: 2017/12/07

Reference Information

CVE: CVE-2018-1336