Apache Tomcat 7.0.x < 7.0.76 / 8.0.x < 8.0.42 / 8.5.x < 8.5.12 / 9.0.x < 9.0.0.M18 Improper Access Control

Medium Nessus Plugin ID 121120

Synopsis

The remote Apache Tomcat server is affected by an improper access control vulnerability.

Description

According to its self-reported version number, the Apache Tomcat instance listening on the remote host is 7.0.x prior to 7.0.76, 8.0.x < 8.0.42, 8.5.x < 8.5.12 or 9.0.x < 9.0.0.M18. It is, therefore, affected by the following vulnerability:

- An improper access control vulnerability exists when calls to application listeners do not use the appropriate facade object. This allows untrusted applications to potentially access and modify information associated with other web applications.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 7.0.76 / 8.0.42 / 8.5.12 / 9.0.0.M18 or later.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.76

http://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.0.42

http://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.5.12

http://www.nessus.org/u?3f871212

Plugin Details

Severity: Medium

ID: 121120

File Name: tomcat_7_0_76.nasl

Version: 1.1

Type: remote

Family: Web Servers

Published: 2019/01/11

Updated: 2019/01/11

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2017-5648

CVSS v2.0

Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

CVSS v3.0

Base Score: 9.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Patch Publication Date: 2017/03/16

Vulnerability Publication Date: 2017/01/29

Reference Information

CVE: CVE-2017-5648