Apache Tomcat 7.0.x < 7.0.70 / 8.0.x < 8.0.36 / 8.5.x < 8.5.3 / 9.0.x < 9.0.0.M8 Denial of Service

High Nessus Plugin ID 121119

Synopsis

The remote Apache Tomcat server is affected by a denial of service vulnerability.

Description

According to its self-reported version number, the Apache Tomcat instance listening on the remote host is 7.0.x prior to 7.0.70, 8.0.x < 8.0.36, 8.5.x < 8.5.3 or 9.0.x < 9.0.0.M8. It is, therefore, affected by a denial of service vulnerability:

- A denial of service vulnerability was identified in Commons FileUpload that occurred when the length of the multipart boundary was just below the size of the buffer (4096 bytes) used to read the uploaded file if the boundary was the typical tens of bytes long.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 7.0.70 / 8.0.36 / 8.5.3 / 9.0.0.M8 or later.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.70

http://www.nessus.org/u?ecb3da27

http://tomcat.apache.org/security-9.html#Fixed_in_Apache_Tomcat_9.0.0.M8

Plugin Details

Severity: High

ID: 121119

File Name: tomcat_7_0_70.nasl

Version: 1.1

Type: remote

Family: Web Servers

Published: 2019/01/11

Updated: 2019/01/11

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2016-3092

CVSS v2.0

Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Patch Publication Date: 2016/06/20

Vulnerability Publication Date: 2016/03/10

Reference Information

CVE: CVE-2016-3092