Apache Tomcat < 7.0.2 Denial of Service and Information Disclosure

Medium Nessus Plugin ID 121115

Synopsis

The remote Apache Tomcat server is affected by denial of service and information disclosure vulnerability.

Description

According to its self-reported version number, the Apache Tomcat instance listening on the remote host is prior to 7.0.2. It is, therefore, affected by a denial of service vulnerability which could also lead to information disclosure. A remote attacker could trigger flaws in the handling of the Transfer-Encoding header to cause a denial of service or potentially leak information.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 7.0.2 or later.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.2

Plugin Details

Severity: Medium

ID: 121115

File Name: tomcat_7_0_2.nasl

Version: 1.1

Type: remote

Family: Web Servers

Published: 2019/01/11

Updated: 2019/01/11

Dependencies: 39446

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2010-2227

CVSS v2.0

Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Patch Publication Date: 2010/08/11

Vulnerability Publication Date: 2010/07/13

Reference Information

CVE: CVE-2010-2227