Fedora 29 : libgxps (2019-8e9789a629)

Medium Nessus Plugin ID 121079

Synopsis

The remote Fedora host is missing a security update.

Description

libgxps 0.3.1 release.

- Fix font scaling when converting xps to pdf

- Handle errors returned by archive_read_data in GXPSArchive

- Ensure gxps_archive_read_entry() fills the GError in case of failure

- Make the pdf generated by xpstopdf to be 96 dpi

- Fix OUTPUT FILE description in man pages

- Clear the GError before trying to load an image again in gxps_images_get_image()

- Fix integer overflow in png decoder

Note that Tenable Network Security has extracted the preceding description block directly from the Fedora update system website.
Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected libgxps package.

See Also

https://bodhi.fedoraproject.org/updates/FEDORA-2019-8e9789a629

Plugin Details

Severity: Medium

ID: 121079

File Name: fedora_2019-8e9789a629.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2019/01/11

Updated: 2019/09/23

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:fedoraproject:fedora:libgxps, cpe:/o:fedoraproject:fedora:29

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

Patch Publication Date: 2019/01/10

Vulnerability Publication Date: 2018/05/06

Reference Information

CVE: CVE-2018-10767