XTreme ASP Photo Gallery adminlogin.asp Multiple Parameter SQL Injection

high Nessus Plugin ID 12020

Language:

Synopsis

The remote web server contains an ASP script that is affected by a SQL injection flaw.

Description

The remote host appears to be running XTreme ASP Photo Gallery.

There is a flaw in the version of this software installed on the remote host that may allow anyone to inject arbitrary SQL commands, which may in turn be used to gain administrative access on the remote host.

Solution

Unknown at this time.

See Also

https://www.securityfocus.com/archive/1/350028

Plugin Details

Severity: High

ID: 12020

File Name: xtreme_gallery_sql_injection.nasl

Version: 1.27

Type: remote

Family: CGI abuses

Published: 1/16/2004

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information

VPR

Risk Factor: Medium

Score: 6.6

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:H/RL:OF/RC:C

Vulnerability Information

Required KB Items: www/ASP

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No exploit is required

Vulnerability Publication Date: 1/15/2004

Reference Information

CVE: CVE-2004-2746

BID: 9438

CWE: 89