GLSA-201812-10 : GKSu: Arbitrary command execution

Medium Nessus Plugin ID 119944

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201812-10 (GKSu: Arbitrary command execution)

A vulnerability was discovered in GKSu’s gksu-run-helper.
Impact :

An attacker could execute arbitrary commands.
Workaround :

There is no known workaround at this time.

Solution

Gentoo has discontinued support for GKSu and recommends that users unmerge the package:
# emerge --unmerge 'x11-libs/gksu'

See Also

https://security.gentoo.org/glsa/201812-10

Plugin Details

Severity: Medium

ID: 119944

File Name: gentoo_GLSA-201812-10.nasl

Version: 1.1

Type: local

Published: 2018/12/31

Updated: 2018/12/31

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:gksu, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2018/12/30

Reference Information

CVE: CVE-2014-2886

GLSA: 201812-10