Node.js multiple vulnerabilities (November 2018 Security Releases).
High Nessus Plugin ID 119938
DescriptionThe version of Node.js installed on the remote host is 6.x prior to 6.15.0, 8.x prior to 8.14.0 or 10.x prior to 10.14.0 or 11.x prior to 11.3.0.
Therefore, it is affected by multiple vulnerabilities.
- OpenSSL Timing vulnerability in DSA signature generation (CVE-2018-0734).
- OpenSSL Timing vulnerability in ECDSA signature generation (CVE-2018-0735).
- OpenSSL Microarchitecture timing vulnerability in ECC scalar multiplication (CVE-2018-5407).
- Debugger port 5858 listens on any interface by default CVE-2018-12120).
- Denial of Service with large HTTP headers (CVE-2018-12121).
- Slowloris HTTP Denial of Service (CVE-2018-12122).
- HTTP request splitting (CVE-2018-12116).
Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.
SolutionUpgrade Node.js to 6.15 / 8.14.0 / 10.14.0 / 11.3.0 or later