INN < 2.4.1 Control Message Handling Code Overflow

High Nessus Plugin ID 11984


The remote host is affected by a buffer overflow vulnerability.


The remote host is running INN 2.4.0.

There is a known security flaw in this version of INN that could allow an attacker to execute arbitrary code on this server.


Upgrade to version 2.4.1 or later.

See Also

Plugin Details

Severity: High

ID: 11984

File Name: inn_control_message_overflow.nasl

Version: $Revision: 1.15 $

Type: remote

Published: 2004/01/08

Modified: 2016/10/27

Dependencies: 17975

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2004/01/07

Reference Information

CVE: CVE-2004-0045

BID: 9382

OSVDB: 6872