IBM WebSphere Application Server 8.0.0.x <= 8.0.0.15 / 8.5.x < 8.5.5.14 / 9.0.0.x < 9.0.0.9 Installation Verification Tool Cross-site Scripting (XSS) Vulnerability (CVE-2018-1643)

Medium Nessus Plugin ID 119678

Synopsis

The remote web application server is affected by a cross-site scripting vulnerability.

Description

The IBM WebSphere Application Server running on the remote host is version 8.0.0.0 through 8.0.0.15, 8.5.x prior to 8.5.5.14, or 9.0.0.x prior to 9.0.0.9. It is, therefore, affected by a cross-site scripting (XSS) vulnerability due to improper validation of user-supplied input before returning it to users. An unauthenticated, remote attacker can exploit this, by convincing a user to click a specially crafted URL, to execute arbitrary script code in a user's browser session.

Solution

Upgrade to IBM WebSphere Application Server 8.5.5.14 or 9.0.0.9 or later. Alternatively, upgrade to the minimal fix pack levels required by the interim fix and then apply Interim Fix PI98558.

See Also

https://www-01.ibm.com/support/docview.wss?uid=ibm10716857

Plugin Details

Severity: Medium

ID: 119678

File Name: websphere_cve-2018-1643.nasl

Version: 1.2

Type: remote

Family: Web Servers

Published: 2018/12/14

Updated: 2019/04/11

Dependencies: 57034

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-1643

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:/a:ibm:websphere_application_server

Patch Publication Date: 2018/11/12

Vulnerability Publication Date: 2018/11/12

Reference Information

CVE: CVE-2018-1643

BID: 106032