lighttpd < 1.4.51 Multiple Vulnerabilities

Medium Nessus Plugin ID 119608

Synopsis

The remote web server is affected by multiple vulnerabilities

Description

According to its banner, the version of lighttpd running on the remote host is prior to 1.4.51. It is, therefore, affected by the following vulnerabilities according to its release notes:

- An unspecified header processing vulnerability in core

- An unspecified username vulnerability in mod_userdir

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to lighttpd version 1.4.51.

See Also

https://www.lighttpd.net/2018/10/14/1.4.51/

Plugin Details

Severity: Medium

ID: 119608

File Name: lighttpd_1_4_51.nasl

Version: 1.2

Type: remote

Family: Web Servers

Published: 2018/12/06

Updated: 2018/12/12

Dependencies: 106628

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: manual

CVSS Score Rationale: Score based on analysis of the vendor advisory.

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: cpe:/a:lighttpd:lighttpd

Required KB Items: installed_sw/lighttpd, Settings/ParanoidReport

Patch Publication Date: 2018/10/14

Vulnerability Publication Date: 2018/10/14