lighttpd < 1.4.50 Multiple Vulnerabilities

high Nessus Plugin ID 119607

Synopsis

The remote web server is affected by multiple vulnerabilities

Description

According to its banner, the version of lighttpd running on the remote host is prior to 1.4.50. It is, therefore, affected by the following vulnerabilities according to its release notes:

- An unspecified potential path traversal in mod_alias

- An unspecified user-after-free in core

- An unspecified path traversal in mod_alias

- An unspecified user-after-free in core

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to lighttpd version 1.4.50 or later.

See Also

https://www.lighttpd.net/2018/8/13/1.4.50/

Plugin Details

Severity: High

ID: 119607

File Name: lighttpd_1_4_50.nasl

Version: 1.5

Type: remote

Family: Web Servers

Published: 12/6/2018

Updated: 4/27/2020

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2018-19052

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:lighttpd:lighttpd

Required KB Items: installed_sw/lighttpd, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 8/13/2018

Vulnerability Publication Date: 8/13/2018

Reference Information

CVE: CVE-2018-19052